Temporary inability to buy certain assets
Incident Report for Coinberry
Resolved
This incident has been resolved.
Posted Feb 28, 2023 - 14:05 EST
Monitoring
The trading (BUYS and SELLS) for RUNE has been temporarily disabled:

Customers existing balances are unaffected.

We appreciate your patience and understanding.

Please do not hesitate to contact our support staff if you want assistance.
Posted Jan 25, 2023 - 17:25 EST
This incident affected: Trading.