Terra LUNA
Incident Report for Coinberry
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 15:09 EST
Monitoring
The Terra (LUNA) blockchain is experiencing network disruption and emergency maintenance. All Terra (LUNA) trading (BUYS and SELLS) are suspended immediately by Coinberry. Customer existing balances are not impacted. We will continue to keep a close eye on the situation and keep our users informed.

During this period, we appreciate your patience and understanding.

Please do not hesitate to contact our support staff if you want assistance.
Posted May 13, 2022 - 11:31 EDT
This incident affected: Trading.