ETH Network Congestion
Incident Report for Coinberry
Resolved
ETH network congestion issues have been resolved and ETH withdrawals are fully functional. Thanks for your patience.
Posted May 10, 2021 - 19:17 EDT
Identified
Coinberry is currently investigating congestion in the ETH network. Both the web and mobile apps are affected. Our I.T. department is aware and currently investigating. We are confident this is not a security matter and your account and funds are safe.

This is affecting only users attempting to withdraw ETH. All other services are running normally. We recommend waiting for a few hours or an update before making an ETH withdrawal or funding your account with ETH.

Please be patient as our team investigates the network congestion and works to restore services.

We will post an update in 1-2 hours.
Posted May 10, 2021 - 17:08 EDT
This incident affected: Crypto withdrawals (ETH withdrawals).