Blocked Customer Service Tickets
Incident Report for Coinberry
Resolved
This issue has been resolved. All email operations are functioning normally.
Posted Mar 12, 2021 - 10:42 EST
Identified
Some replies to our customer service tickets were unintentionally blocked by a security update implemented on March 4.

All of our members currently waiting for replies to customer service emails are affected and should expect an extended wait time for case resolution.

Our I.T. department has identified and resolved the issue. All customer service replies are coming into our system normally now.

This is not a security matter and your account and funds are safe.

If your case is urgent, please re-submit it.

Please be patient as our team works through several days of support tickets.

We will post a daily update.
Posted Mar 11, 2021 - 15:14 EST
This incident affected: Customer Support and Email.