ETH Funding Delays
Incident Report for Coinberry
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 15:55 EDT
Identified
ETH funding is delayed while we work on a technical issue. Some members funding with ETH will experience transaction delays.

Our I.T. department has identified the issue and our team is currently working on a solution. This is not a security matter and your account and funds are safe.

Please be patient as our team works to restore our ETH funding transaction times.
Posted Apr 17, 2021 - 11:16 EDT
This incident affected: Crypto funding (ETH funding).