Degraded Performance of Crypto and Fiat withdrawals
Incident Report for Coinberry
Resolved
Crypto and fiat withdrawals are fully operational.

We understand that service disruptions can be frustrating, and we apologize for any inconvenience.
Posted Jul 30, 2021 - 14:22 EDT
Investigating
Fiat and Crypto withdrawals are partially degraded while we address a service issue. We understand that financial inconveniences can be frustrating and we apologize for the inconvenience. We want our investors to be assured that their accounts are secure. Please monitor for further updates.
Posted Jul 23, 2021 - 16:14 EDT
This incident affected: Crypto withdrawals (BTC withdrawals, ETH withdrawals, XRP withdrawals, LTC withdrawals) and CAD Withdrawals.