Delayed Withdrawals
Incident Report for Coinberry
Resolved
This incident has been resolved.
Posted May 23, 2020 - 18:03 UTC
Monitoring
On May 11, 2020 we became aware of a delay in processing withdrawal for a small group of our users.
We immediately started working on a solution, which has been put in place. We’d like to apologize for any inconveniences caused. We understand that these things can be frustrating. The safety and security of our members' cryptocurrency and accounts is our highest priority.
Posted May 11, 2020 - 18:50 UTC